Blank Screen and not full track record.

Home Page Forums Cymatic Audio Forum Blank Screen and not full track record.

This topic contains 2 replies, has 2 voices, and was last updated by Matt Cox Matt Cox 4 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #38690
    Matt Cox
    Matt Cox
    Participant

    Hi Guys,

    I’m using Track 24 to record live shows, but the screen has gone blank on the unit… this means its faulty right?!
    I can still operate the unit using U Remote but despite setting up for 24 track recording only 11 tracks are actually recorded when used, even after a re-format of my external drive. I ‘ve lost 2 shows now so am wondering if a new unit is the way forward?.

    Can you advise on whether a firmware update might resolve the screen issue or is the unit faulty.

    Many thanks ..

    Matt.

    #38693
    Laszlo .
    Laszlo
    Keymaster

    Hi Matt,

    Unfortunately this sounds like an hardware issue.
    You have two options:
    1. If the device under warranty you should ask a replacement device
    2. If there’s no warranty anymore, you can try to remove the top cover then check the ribbon cable connection between the screen and main board (most likely this cable is loose)

    We are sorry for the inconvenience

    #38750
    Matt Cox
    Matt Cox
    Participant

    Thanks for the reply Laszlo, sadly I’m out of warranty.

    A new unit might be most most reliable option right now with some background maintenance on the current one.

    Cheers again ..

    Matt.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.