broken output sockets anyone?

Home Page Forums Cymatic Audio Forum Live Player LP-16 broken output sockets anyone?

Tagged: , ,

This topic contains 3 replies, has 2 voices, and was last updated by Laszlo . Laszlo 6 days, 12 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #46824
    stev
    stev
    Participant

    Anyone suffered from broken output jack sockets?

    It appears the top row are only secured by “push-fit” retention.
    A light downward knock on a jack plug inserted to the top row of sockets may be enough to detach the socket from its mount.

    I have experienced this recently and should it happen in a live situation it could be a major issue. Can be fixed with superglue but be better if sockets were mounted to chassis or better retained.

    #46838
    Laszlo .
    Laszlo
    Keymaster

    Hi Stev,

    Those type of connectors were present ages ago in the very first revision of LP-16.
    We had correct that immediately with new revision.

    #46904
    stev
    stev
    Participant

    thanks for the feedback. Do the newer unit just have different jack sockets or have you implemented a PCB redesigned to accommodate?

    Any tips or suggestions to make my unit more robust?

    thanks

    #46973
    Laszlo .
    Laszlo
    Keymaster

    Hi this issue got resolved by using different Jack sockets.
    To be honest I haven’t heard any user with broken jack connector, I’m pretty sure the device is robust enough.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.