Midi Export not working with new computer

Home Page Forums Cymatic Audio Forum uTrack 24 Midi Export not working with new computer

This topic contains 4 replies, has 2 voices, and was last updated by Jeroen Schlaman Jeroen Schlaman 17 hours, 15 minutes ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #53566
    Luke
    Luke
    Participant

    Hello, I have been using my utrack24 for about a year. Exporting midi with logic to cue lighting has been flawless so far. I just bought a new computer and now every time I export a midi file on my new computer with the same process it says it is 1:06:40 long every single time no matter how long it actually is…

    I can open the same midi file back into Logic and it looks fine but then when I add it into Utool it says it is 1:06:40 again on every song.

    #53762
    Jeroen Schlaman
    Jeroen Schlaman
    Participant

    Looks like an issue I’ve been running in recently.
    First I only had one MIDI file for lighting control. Because I want to switch two guitar processors as well I created two separate MIDI tracks for that on different channels.
    Logic will now save the MIDI file as format 1, resulting in uTool (and other tools as well) showing this MIDI file not the actual track length but around one hour.

    I’ve investigated and found out that Logic Pro adds a very long time length to the ‘tempo track’ (the first track in a format 1 MIDI file). Why? No clue so far but at this moment a show-stopper. In some MIDIs it even put 96 (!) tempo tracks in place.
    Format 0 works fine and results in the correct track length, format 1 completely screws this.

    Did you run an older version of Logic on your old computer by any chance?

    The search continues….

    #53772
    Luke
    Luke
    Participant

    Thanks for the reply, so I have had the issue of the 0 or 1 midi format before so I did uncheck that box in Logic and that part was fine. I ended up reinstalling an older version of Logic 10.3 on my new computer and it exports fine as long as that 0 box is checked. However if I update to the new version of Logic no matter if it is 0 or 1 it is unusable and is always that 1:06:40 length for some reason. Got to love updates…

    #53782
    Luke
    Luke
    Participant

    That being said if I open the midi track back up in Logic it looks identical to the correct one. However when I load it into the player in troop it says it is that 1:06:40 length

    #54290
    Jeroen Schlaman
    Jeroen Schlaman
    Participant

    Well, the checkbox you mention works like this:
    When checked: Single regions will be saved as format 0, multiple regions as format 1
    When unchecked: Always saved in format 1.

    I’ve the newest version of Logic as well so according to your experience this issue is something from more recent versions unfortunately.

    It’s indeed no problem when you import the MIDI file back in. It’s just that other MIDI players, including uTool, will show you a way to long MIDI-file time.
    Normally the first track (tempo track) will be ignored so it will only count the actual MIDI tracks. But as Logic writes a whole bunch of tempo tracks with this 1 hour time it just uses this.

    For now my workaround is that I import each Logic-exported MIDI in Pro-Tools First (free version) and save it without any editing from within Pro-Tools (select format 1). The MIDI file will now be correct (and will a fifth of the file size again).

    I just can’t imagine Logic being faulty when exporting MIDI Format 1 so still looking into this problem.
    I’m now planning to write a converter for this to skip the Pro-Tools part.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.