uTrack-X32 not recognised by X32 mixer OR Windows PC

Home Page Forums Cymatic Audio Forum uTrack-X32 uTrack-X32 not recognised by X32 mixer OR Windows PC

This topic contains 3 replies, has 2 voices, and was last updated by Ruth Gunstone Ruth Gunstone 1 year, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29394
    Ruth Gunstone
    Ruth Gunstone
    Participant

    Hello!

    I have just installed a new uTrack-X32 into a (also new) Behringer X32.

    I have installed the drivers on the PC. (CymaticAudio_X32_V6_19_1_signed) (PC running windows 10)
    I have installed the latest firmware on the uTrack-X32 (uTRACKX32_Release_3865)
    I have updated the desk to the latest firmware (3.08)

    Still, the Behringer desk does not recognise the card is plugged-in and the PC doesn’t see the uTrack-X32

    Am I to assume the uTrack-X32 is broken? 🙁

    Any help/advice welcome!

    Ruth

    #29399
    Ruth Gunstone
    Ruth Gunstone
    Participant

    Replying to my own post . . .

    This morning, I started from scratch. Removed the card and re-installed it. Suddenly, everything is working! “Go Figure”, as they say!

    #29405
    Laszlo .
    Laszlo
    Keymaster

    Hi,

    Thank you for your input.
    If you experiencing any issue with the card, please do not hesitate to contact with us.

    #29415
    Ruth Gunstone
    Ruth Gunstone
    Participant

    Pleased to report all OK so far! Just tested with a USB3 SSD (240GB) and it seems to be happy.

    Regards,
    Ruth

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.