can’t install drivers

Home Page Forums Cymatic Audio Forum uTrack 24 can’t install drivers

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #26673
    Anders BAnders B
    Participant

    I am trying to install the Windows drivers, but in the end the installation keeps saying: “Please disconnect and reconnect the device…” I do that but it doesn’t help. The dialogue box keeps popping up again and again. I tried installing without the uTrack 24 connected, I tried with it connected, I tried restarting Windows. Nothing helps. I am stuck in this installation loop.

    Please help.
    Br, Anders

    #26674
    Tom SailorTom Sailor
    Participant

    Do you have a hard drive connected to the uTrack24?

    #26675
    Anders BAnders B
    Participant

    I disconnected it while installing…

    #26677
    Laszlo .Laszlo
    Keymaster

    Did you see any change on the uTrack24 display when you connect to the pc?
    It display interface mode?

    Do you have any other USB audio device connected to the pc? You can try to removing any other USB device, reboot the pc, connect the uTrack24 then start the driver installer.

    Which os?

    #26678
    Anders BAnders B
    Participant

    1) When I connect uTrack24, the display says: USB Interface Mode
    2) No, I don’t have any other USB audio devices connected.
    3) Windows 7

    Still no luck, the dialogue box pops up. I disconnect and reconnect the USB cable. I push ok….the dialogue box pops up again. And so on….

    Please help!

    #26681
    Laszlo .Laszlo
    Keymaster

    Please connect your uTrack24 to the PC, start the driver installer, when it ask to disconnect/reconnect the uTrack24 remove the power connector (leave the USB connected) then connect the power jack to the uTrack24.
    If still not working, please open the control panel and manually remove the uTrack24 diver, reboot the PC and start the driver installation again.
    Please also try to re-download the uTrack24 driver https://cymaticaudio.com/downloads

    #26708
    Anders BAnders B
    Participant

    I reinstalled manually and restarted Windows. After that, the installation worked. Thanks!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.