Driver install fails-No Digital Sig(V6.19, FW2905)

Home Page Forums Cymatic Audio Forum uTrack-X32 Driver install fails-No Digital Sig(V6.19, FW2905)

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #27748
    Gabriel A PassGabriel A Pass
    Participant

    Driver installation fails on Windows 10 “Windows cannot verify the digital signature for the drivers… (Code 52)”

    • Driver version 6.19
    • uTrack-X32 Firmware 2905
    • Windows x64 10 Latest updates (Version 1607 for x64-based Systems (KB3206632)

    Just bought the uTrack and trying to get it working. Can anyone advise on how to solve this problem?
    Thanks.

    #27755
    Laszlo .Laszlo
    Keymaster

    Hi,

    To updating the firmware you don’t need any driver.
    Please use the network update method, where no driver needed.

    #27756
    PeterPeter
    Participant

    I hope that you intended, that you want to update the firmware of the card .????

    Here is some solution
    Which internet explorer you use, I have a problem to update with windows IE.
    After some testing I try to update the firmware with Google chrome, that’s works for me.
    The second card I update direct with Chrome without any problem.

    Greetings Peter Visscher
    Sorry for my bad English I’m from Holland

    #27779
    Gabriel A PassGabriel A Pass
    Participant

    So sorry! I was trying to include all the essential details in the post subject line, and running out of room wrote “FW” instead of Driver.

    I edited my original post. So now it should make sense.
    When installing the uTrack-X32 Driver & ControlPanel in Windows, the install goes fine, but on connecting the hardware, the driver is not accepted because it states that it doesn’t have a correct digital signature.
    I did want to mention that I had the latest firmware. (I updated prior to installing the drivers. Since this FW was just released, I thought that might have made a difference.)
    I hope that makes sense now, and thanks for your response.

    #27780
    Laszlo .Laszlo
    Keymaster

    This is really strange because the driver signature checked right after where you start the exe then if not signed successfully the installer wont start at all.
    Can you please do a following steps to see where the problem occur?:
    1.Disconnect the uTrack-X32 from your PC (preferably disconnect all USB device from your PC except mouse and keyboard)
    2. Uninstall the driver (settings/system/apps & features) [cymatic audio uTrack-X32 USB driver]
    3. Reboot your PC, make sure the uTrack-X32 not connected to your PC
    4. Start CymaticAudio_X32_V6_19_0.exe –> You should see a “user account control” popup message on your screen: “Do you want to allow this app to make changes on your device” –> select YES
    5. Now you should see the driver installer welcome screen –> select next
    6. The next screen is the install location –> select install
    7. The install should start
    8. You’ll see a popup message: “please disconnect and reconnect the device you wish to install and turn it on”
    9. Make sure your uTrack-X32 powered on, then connect the USB cable to your PC and click on the OK in the popup window.
    10. Now you should have a driver properly installed.

    If you have some problem, please let me know where the problem happens.

    #27785
    Gabriel A PassGabriel A Pass
    Participant

    Thanks for you quick response. It’s not fully solved, but your advice helped me track down the problem.
    The drivers installed fine and are working on a different Windows 10 computer. So fortunately I am able to use the interface now.

    The computer where the drivers won’t install is a new HP ZBook Mobile Workstation. After probing around a bit, I believe something about the uTrack driver triggers a flag in Windows TrustedInstaller which may halt installation on a computer with a “Secure Boot policy” on UEFI Firmware. When I followed your instructions I received the exact same result every time on the ZBook. So I think this additional layer of security, is what prevents the driver from installing.

    I am aware that driver signature verification can be disabled by turning on “Test Signing Mode” in cmd. But I would like this to work without going to those lengths, and at least I have it working on one computer now.
    In case it’s helpful, I included some screenshots to show you what’s going on.



    #27788
    Laszlo .Laszlo
    Keymaster

    Thank you for the screenshots.
    This is really helpful.
    Could you please tell me what error message displayed where you double click on the yellow exclamation mark at the first screenshot?

    #27843
    Gabriel A PassGabriel A Pass
    Participant

    It just says the device failed to start because the driver’s digital signature was incorrect.

    #27869
    Laszlo .Laszlo
    Keymaster

    This only happens on the Windows 10 releases which not upgraded from earlier release.
    We are working on the solution.
    At the moment the only way to get it work by disabling the secure boot on the PC this should allow to install those drivers.
    Actually our drivers are signed but the Microsoft changed the driver signature policy so this is the reason why those PC’s says the drivers are not signed

    #27874
    Gabriel A PassGabriel A Pass
    Participant

    That makes sense. I am admin on the PC but our IT staff have the laptop locked through the BIOS with secure boot enabled. I’ll just work with them to get that unlocked or wait until the Windows updates take care of the problem.

    Thanks.

    #28244
    RenschlerRenschler
    Participant

    Maybe you find a way to put in a windows registry key to allow this kind of signature type?
    I try to find the correct windows hotfix for windows 8.1 but I failed. For me it looks like a windows problem.
    I solved it by restarting windows without driver signature check.
    I hope this will work permanetly after many windows restarts.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.