Home Page Forums Cymatic Audio Forum uTrack 24 Firmware update problem – urgent

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
  • #26826
    Andy Highmore

    Hi there,

    I just received 2 uTrack 24’s to use for playback with a couple of artists i work with, and i have just been trying to update the firmware to the latest version.

    I downloaded the updater ok (for Mac via USB), and started the update process. However, every time it doesn’t work and the reading on the front of the u-Track says ‘Firmware upgrade: download failed! try again.’

    I have now tried many times and the same thing happens each time….

    Also the unit now seeming can’t be used at all until i upgrade the firmware (which doesn’t work!).

    Any idea how to fix this and upgrade to the latest firmware successfully?

    Thanks a lot,

    Andy Highmore


    Hi Andy,

    Sorry to hear you had problem with uTrack24 firmware update.
    I sent you email to further action to take.


    Hi Laszlo,
    I have the same issue. Firmware update via USB (Windows 64bit)
    I received message “upgrade failed. error code 0x1f”
    After retrying that several times I tried the network firmware update.
    It gets to ‘Burning flash…’ but then gives the message “Error writing to flash memory”.

    Please send me the instructions to get past this.



    Hi dennml,

    I sent you the instructions in email.


    I am also having trouble updating the firmware. Tried USB (OSX) and Network. Both methods fail. Help please.


    Hi ekaudio,

    I sent you email to further action to take.


    HI Just purchased and I have exactly the same issue and the same error code
    Why do you not post the instructions you have emailed If you had I could have tested them rather than waiting for a reply to my email sent today marked urgent!l
    You seem to be aware of this issue so at the moment I have a brand new machine which is now useless as a result of your large instruction ( a4 page in yellow at the top of the box) telling me upgrade immediately to the latest version of firmware! I didn’t get 1 minute of use before a problem!
    Not good


    Dear users,

    We recently have become aware of a sporadic hardware glitch in the flash memory of the device, causing the firmware update to fail.
    Should you experience such problems where the firmware updates fails, please contact your dealer/ distributor for support.
    Defective hardware is being replaced under warranty thru the dealer/distributor you purchased the unit from.

    The update to firmware version 3124 is important because it solves the potential hardware issue in the firmware.

    All current deliveries from our inventories and other newer devices in the pipeline already updated to fw version 3124 are not affected by this hardware issue.

    Kind regards,

    Cymatic Audio EMEA-support


    Dear Monmol,

    As you may have seen, our messages may have crossed on this forum as we just have posted an announcement on the topic.

    Truth be told, it took indeed some time to weed out the regular problems caused by computers, drivers and so on and recognize that under certain circumstances, there is a hardware glitch potentially makes the firmware update fail.
    Thru the active input from users like yourself on this forum we have recognized the issue now and are working with our local dealers and distributors to make the appropriate measures.

    We like to thank our user-base for their active support and apologize for the inconvenience.

    Kind regards,
    Cymatic Audio Support

    Marc Trainor

    I’ve had the U-trak 24 for some time now, maybe a year or so, and while trying to update to the 3124 firmware update, everything seems to go ok, until I get to the part where a message comes on saying: Unplug and replug your unit and turn it on. When I do that, the same message keeps coming up to do it again. It never gets done, and when I click exit, it says update failed. I wonder if this is a hardware issue too. Marc Trainor.


    Hi marcbonnie777,

    That doesn’t seems hw issue, it looks USB communication issue.
    Please update your device with network update method.

    Marc Trainor

    I was finally able to update the new firmware using the network plug on my computer and U-track, I had some weird problems getting it done, but I finally was able to do it. Marc Trainor.

    Hudson Fair

    I have an emergency here. I need to update my firmware to 3474 be able to use the ADAT option card.
    Every update method I try does not work.
    Presently my unit has firmware 2469.

    USB connection update by plugging in to the rear shows “no device present.” Won’t work.
    Network update with ethernet cable goes on for 3 hours without finishing the update. Won’t work.

    Please address this problem as I need to record in two days with the unit.



    Hi hrfair,

    Please use the network update method.
    Make sure, the device in idle state (no playback or recording)
    Connect the uTrack24 network cable to the network where your PC/MAC connected (you can connect directly to your PC/MAC as well).
    Check the IP address on the uTrack24 (settings/utilities/system details)
    Type this ip address to your browser (Chrome or safari preferred)
    Drag and drop the bcd file from your file browser to the browser update screen.
    You should see a progress bar on the uTrack24. When is done, select the reboot in your browser, or manually power cycle the uTrack24.

    If you see any error message in your browser please let me know.

    Ruud van Steenis

    Hello, I just tried to update the firmware to the latest version.
    So I copied uTRACK24_Release_3474.bcd to an (for the rest empty) USB stick, but the only thing that happened was that I was asked if I would format the USB drive. (Again!)
    Of course that is not what I want. I will try to update using the network method, but I think this still requires some attention!


    Hi, i’m getting this ERROR 0x1f after been running Firmware v3124 Updater. (similar situation with Williams who wrote Error code 0x1f Topic)
    I’ve tried different methods and none is uploading firmware correctly. Has result firmware update fails and no firmware is running at the moment so i can’t either see the IP or build-in firmware version, but i’m pretty sure it was v2016 (or under).
    Please help me to fix this situation.
    I bought this new about 6 moths ago…. still want to use much more.


    Hi Adubodub

    I would like to know what firmware version was on the device before you started to update.

    The current version 3474, as I seen correctly you tried to install the 3124 release from February is that correct?

    You can discover your uTrack24 IP address easily if you connect the uTrack24 to a router then you connect your iPhone/Android phone to the same router then start the Fing https://www.fing.io/ application.

    If you already know the ip address please type that address in your browser (MAC/PC) chrome browser preferred then drag and drop the 3474 bcd file to start the update.

    Michael O’Hara

    I Have :ohmy: no current issues but would like to know if my Utrack 24 will be one of these devices with the faulty flash memory before I find out the hard way. How can I determine if mine is defective? Thanks


    Hi Bigego,

    If your device already updated to 3124 or 3474 firmware release you are on the safe side. We changed the update method so you don’t need to worried about this.
    The faulty flash devices should failing during the update to 3124 or 3474.


    i’m not sure which firmware was on the device!

    (before starting update) This was what i remember when looking at the System Details menu
    2016 (is this one the date or firmware version?)
    1543 (i think the nr. here was something like this or close) (IP Address)

    After following all steps, having uTrack24 connected to the network router, and finding the IP with Fing app, i was able to open html drag and drop network firmware updater where i dropped the latest version 3474 (progress bar works both at the uTrack and computer) Resulting in a message at html saying
    Error writing flash memory,
    and a message at uTrack24 saying
    system error power cycle dev. and try again

    What should i do now?



    Hi Adubodub,

    That is not too good news.
    That was the main reason why we forced our users to update the device soonest as possible to the latest release, because with the new firmware release that issue can solved. As I seen correctly that v2016 firmware is some of the very first releases from October 2014.
    The best thing what you can do, please contact with your distributor where you bought the device and explain them the same thing what you wrote here.
    If you need further assistance in this matter please do not hesitate to contact with us in support_at_cymaticaudio_dot_com

    Sorry for the inconveniences.



    my system :
    Firmware 1779
    Bootloader 1650
    IP Adress

    impossible to mount a usb card with there new driver on the root of the Usb card
    Impossible to get any adress IP with an ethernet connection
    Mac os 10.11
    Please Help

    Claude from Paris


    Hi Claude,

    Please connect your uTrack24 to any router. Go to the Settings/utilities/system details note the ip address.
    Connect your MAC to the same router then type the IP address to your browser, then follow the on screen instructions.


    Thanks a lot it works well

    now i put my Madi card in the slot


    Shawn Fenton

    I have the exact same issue that Adubodub reported. I purchased the unit new last month and attempted to update the firmware to 3474. I do not remember the exact number of the existing firmware on the unit, but it was a much lower number, at least in the 2000s. I used the network method, connecting directly to a computer. I found the IP address fine, got the browser to work, selected the 3474 update file, and then after the status bar completed I had the “system error power cycle dev. and try again” message on the unit, and the browser says “Error writing to flash memory.” I attempted redoing this several times with the same result.

    Your suggestion to Adubodub was to contact the distributor. Is that still the only thing that can be done? Can I expect the dealer to know this is a legitimate issue?


    Hi ShawnF,

    Sorry to hear this problem.
    It seems the only way to solve this issue to send back the device to the distribution where you bought the device.
    We already made a correction in 3124 firmware release so all of the devices which already updated to this or higher firmware are not infected with this issue.
    We already sent out emails to our distributions to update the devices before they sell the devices. It seems somehow one device with older firmware release slipped out somehow from our distributor. We are really sorry for this issue.
    If you need help to get your device to replace please keep touch with us we are here and ready to help you.

    Sorry for the inconveniences


    I am stuck on this firmware issue now. I tried the network update first, then usb.
    The display just says firmware update do not turn off.
    I can no longer connect via network, usb tries to do the update but then fails…

Viewing 27 posts - 1 through 27 (of 27 total)
  • You must be logged in to reply to this topic.