Folders inside of folders on LP16 and updated Utoo

Home Page Forums Cymatic Audio Forum Live Player LP-16 Folders inside of folders on LP16 and updated Utoo

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #26240
    JONATHAN DONAHUEJONATHAN DONAHUE
    Participant

    Hey Guys,

    So I have updated Utool and have been working on getting it to work all day.

    Still eluding me. It keeps creating Recording Folders inside Recording folders and #Playlist Folder as well as PlaylistLib Folder.
    Very confusing. I will try to get more specific but:

    1.I updated the Utool and erased and then reformatted drive.
    2. This automatically creates a Recording Folder and within that a #Playlist Folder and also a separate Music Folder
    3. I export songs from a separate hard drive and press save.
    4. This automatically creates a SongLib folder and within that a LP16 folder and within that a .songprj.

    So far it looks like this:

    Music Folder
    Recording Folder
    #Playlists
    SongLib
    LP16
    Song One.songprj

    Then i go to export the song into the Recording Folder on the external drive.

    This creates 2 additional folders (a Music and Recording) inside the preexisting Recording Folder

    Music Folder
    Recording Folder
    #Playlists
    Music
    Recording
    #Playlists
    Song One Folder
    SongLib
    LP16
    Song One.songprj

    By now you can see the problem. Recording folders being created inside Recording Folders and multiple #Playlist Folders each time i export new songs.
    When i put the drive into LP16 it sees no songs and i have to navigate using the folder browser deep inside to get to the songs.

    Any suggestions on what i am doing wrong to create multiple Folders inside folders, etc…

    I am supposed to set my project location to something other than the first Recordings folders created during formatting on the external hard drive?
    Should it be set to somewhere else?
    Where should i route the playlists i create?

    Thank you,
    J

    #26243
    ChetanChetan
    Participant

    Hi J,

    The concept is as follows:
    1. The original tracks(mono wave files) are expected to be somewhere on your local drive; lets say c:/Music/MyMonoFiles/
    In the Settings tab, you should choose your Audio library path as c:/Music/MyMonoFiles/
    uTool will never modify the original songs. If the mono files are spread across many folders, you can always choose the right folder before making a new song.

    2. The project files are also expected to be stored on your local drive. Lets say c:/Music/uToolProjects/
    Every time you make a new multi-track song, only a small project file .prj is created. The project file is only used by uTool; with which it knows where the individual mono files are coming from within a multi-track song. The actual song does not exist anywhere unless the song is exported. When the song is exported, the uTool with the help of the .prj file knows where to pick the individual mono wave files for that song. Only the song content is exported and not the project file itself (since the LP-16 does not need to know where the mono files come from)
    Similarly when a playlist is created, it uses the song project files to create a playlist project file. The playlist does not exist anywhere unless it is exported.

    3. Once you prepare all your Songs and Playlists on your local machine, you are ready to export it to an external drive to play on the LP-16. Format your drive, connect it to your PC and just use Export tab to export all the content. All the multi-track folders will be placed in the “Recording” folder and all the “stereo” files in the stereo folder. The respective playlists will be stored in the #PLAYLIST folder.

    The problem I see is that probably your project file location is in an external drive. Since the exporting creates other folders, the project files are messed up. Could you try the above method and let us know if it solves your problem.

    #26369

    Hi digitechan,

    I’m getting more and more frustrated with my LP16: after the first error occurred (song file interruption), which had been cured by the last update, I had similar problems with the folders / subfolders as described by J., making it impossible to play / visualize the songs or playlists on the LP16 from the external USB drive- and even the “Export” button is not functioning properly at all times.

    Even after re-setting the USB device as well as saving the Project Files in my local machine as suggested by you in your message, I still have problems with transferring the edited Playlist including the Multitrack Songs to the USB device: the “Export” button is deactivated, therefore, I had to transfer the Playlist / Multitrack Song files to a local directory/folder first and then copy-paste from the directory/folder to the external USB device-
    and there it is: finally, the songs are displayed on the LP16 as it should have been right from the beginning.

    It seems the “Export” button, which should be transferring all files directly from the uTool / local folder to the USB device, is not functioning properly.

    By the way, I really appreciate this forum and the support provided by the Cymatic team, but, frankly speaking, spending many hours trying to solve problems/bugs without any special programming skills is not really a delightful experience. Please try to keep it as simple as possible…

    Thanks, Ruben

    #26370
    ChetanChetan
    Participant

    Hi Ruben,

    Thanks for the input. We are actually working towards that right now, trying to simplify the use of uTool. Sorry that you had to spend a considerable amount of time due to the complexity.

    The problem with the Export button was fixed in the last version 1.0.1.24, but seems like it does not work on all the PC’s. We did check this with multiple operating system versions of Windows and MAC. It would be very useful for us to know your version of operating system.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.