If drive takes hours to format, is that an error?

Home Page Forums Cymatic Audio Forum uTrack-X32 If drive takes hours to format, is that an error?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27862
    Gabriel A PassGabriel A Pass
    Participant

    Hi I just purchased a HGST Touro S 500GB drive to use with uTrack-X32. I tried to format the drive on the uTrack. It has been flashing red for hours.
    Should I wait, or is that an error?

    Does the uTrack do a a quick format or a full format?

    #27863
    Laszlo .Laszlo
    Keymaster

    Hi,

    Normally it shouldn’t take more than couple of minutes.
    Where you connect the drive with different file system the flashing LED is the warning because the drive not FAT32.
    If the formatting does not succeed you can format the drive on your PC/MAC to FAT32 then connect to the uTrack-X32. Make sure the LED are green which mean the drive ready, then push the format button twice to start the formatting process

    #27914
    Gabriel A PassGabriel A Pass
    Participant

    Ok, I found what I believe is the ideal way to format large drives on windows for Cymatic recorders.

    It would take forever and fail because Windows is not able to format large hard drives using Fat32. But I found a program that works extremely well. It’s called SwissKnife from CompuApps.

    They even released a new version with settings optimized for Cymatic recorders.

    I found this post in your support community explaining that a cluster size of 64K provides the best performance for all of your recorders.
    I contacted their tech support noticing that 64K was not an option for all disks. They just released an update to enable 64K cluster size for any drive.

    The app is very inexpensive and seems like the most effective way to erase drives after recording and optimize large size spinning disk drives for these recorders.

    #27917
    Laszlo .Laszlo
    Keymaster

    Thank you for your message this is a very good tool.
    But it would be nice to know the exact type of the drive which takes to long to format with Cymatic devices, because I just formatted a WD 8TB drive with uTrack-X32 and the process took only couple of minutes

    #27973
    Gabriel A PassGabriel A Pass
    Participant

    Thanks for asking. It’s great that you’re looking into all the details.
    I solved the problem. I tried formatting the drive a second time and it worked. The uTrack-X32 is able to format my drive again once it is already in FAT32 format.

    The drive is a HGST Touro S 7200rpm drive (500gb). I just purchased it for use with the uTrack-X32.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.