Home Page Forums Cymatic Audio Forum uTrack 24 Midi Export not working with new computer

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #53566

    Hello, I have been using my utrack24 for about a year. Exporting midi with logic to cue lighting has been flawless so far. I just bought a new computer and now every time I export a midi file on my new computer with the same process it says it is 1:06:40 long every single time no matter how long it actually is…

    I can open the same midi file back into Logic and it looks fine but then when I add it into Utool it says it is 1:06:40 again on every song.

    Jeroen Schlaman

    Looks like an issue I’ve been running in recently.
    First I only had one MIDI file for lighting control. Because I want to switch two guitar processors as well I created two separate MIDI tracks for that on different channels.
    Logic will now save the MIDI file as format 1, resulting in uTool (and other tools as well) showing this MIDI file not the actual track length but around one hour.

    I’ve investigated and found out that Logic Pro adds a very long time length to the ‘tempo track’ (the first track in a format 1 MIDI file). Why? No clue so far but at this moment a show-stopper. In some MIDIs it even put 96 (!) tempo tracks in place.
    Format 0 works fine and results in the correct track length, format 1 completely screws this.

    Did you run an older version of Logic on your old computer by any chance?

    The search continues….


    Thanks for the reply, so I have had the issue of the 0 or 1 midi format before so I did uncheck that box in Logic and that part was fine. I ended up reinstalling an older version of Logic 10.3 on my new computer and it exports fine as long as that 0 box is checked. However if I update to the new version of Logic no matter if it is 0 or 1 it is unusable and is always that 1:06:40 length for some reason. Got to love updates…


    That being said if I open the midi track back up in Logic it looks identical to the correct one. However when I load it into the player in troop it says it is that 1:06:40 length

    Jeroen Schlaman

    Well, the checkbox you mention works like this:
    When checked: Single regions will be saved as format 0, multiple regions as format 1
    When unchecked: Always saved in format 1.

    I’ve the newest version of Logic as well so according to your experience this issue is something from more recent versions unfortunately.

    It’s indeed no problem when you import the MIDI file back in. It’s just that other MIDI players, including uTool, will show you a way to long MIDI-file time.
    Normally the first track (tempo track) will be ignored so it will only count the actual MIDI tracks. But as Logic writes a whole bunch of tempo tracks with this 1 hour time it just uses this.

    For now my workaround is that I import each Logic-exported MIDI in Pro-Tools First (free version) and save it without any editing from within Pro-Tools (select format 1). The MIDI file will now be correct (and will a fifth of the file size again).

    I just can’t imagine Logic being faulty when exporting MIDI Format 1 so still looking into this problem.
    I’m now planning to write a converter for this to skip the Pro-Tools part.

    JP F.


    I have exactly the same problem using Logic 10.4.6.
    Did you find any solution for this issue ?

    Exporting individual midi file gives me the same length but
    when I export multiple Midi file into one it gives me the extended timing file.
    That happens if I checked Midi Format 0 or not

    Would love to know where you are with this issue

    Toby Craig

    Hey Jeroen,

    Did you end up having any luck with finding or making a shorter work-around? I’m having this issue with the latest logic too. Totally annoying because I have a lot of midi triggers programmed into my logic session for lights, patch changes, controllers etc.

    I tried opening in Pro Tools like you mentioned, but it still ended up exporting 1 hour files. Probably because it was PT Version 11. I’m yet to try with PT Free.

    JP F.

    Hi Toby,

    I’m using Logic and have this problem in the latest build but I still got Logic 10.2.4. So I just open my session in the older version and export it from there. Everything works fine in 10.2.4
    Hope logic will fix this in a later version

    hope that helps

    Toby Craig

    Hey JP,

    Thanks for your reply. Any idea how I could downgrade to 10.2.4 ?

    I’m stuck on the latest version at the moment.

    JP F.

    I also keep my older version of Logic before upgrading by just renaming it so it won’t get replace by the newest one.
    I name the old version Logic Pro X old so the new one installs as Logic Pro X

    If you have the old installer you could do the opposite naming yours : Logic Pro X new and install the other as Logic Pro X

    that should do the trick. Works for me.

    Toby Craig

    Ok cool, I’ll see if I can find an older version.

    Just for the record, I successfully managed to import the Logic midi files into Reaper. After exporting as Format 1 without editing, uTool seemed to have the correct lengths for them.

    I hope logic works in future releases.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.