MT song playback ok, playlist not ok

Home Page Forums Cymatic Audio Forum Live Player LP-16 MT song playback ok, playlist not ok

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #25829
    Steven CowleySteven Cowley
    Participant

    I am having some problems getting a playlist to work on my LP-16. I have created a playlist in the Playlist Editor V2.1 and exported it with all content to a USB drive.

    When I connect this drive to my LP-16, I can play the songs individually. But when I select the playlist, all songs show with a length of 0:00 and will not play. Am I doing something wrong?!

    #25830
    Steven CowleySteven Cowley
    Participant

    Looking at the playlist file in a text editor, I see the following:

    Test playlist

    Song 1

    wait_for_button_press
    10

    And so on for each song. Should there be something between the tags? If so, what should be there – what format should I use to make the LP-16 know where everything is? I’m happy to write these playlists in the text editor, I just need to know if there’s something missing from the playlist file that I have exported.

    Thanks.

    Steve

    #25831
    Steven CowleySteven Cowley
    Participant

    I might be talking to myself here, but I’ll carry on anyway…

    If I select a playlist on the LP-16, each song shows a length of 0:00 as I said before. But if I press the folder contents button and select a song to insert, that song WILL play properly. It’s just songs that are part of the exported playlist that won’t play. Pleeeaaaase can anyone help?!

    #25832
    Steven CowleySteven Cowley
    Participant

    Ok, here we go with another reply to my own question… I think everything is ok now. The firmware displayed on the LP-16 when I booted it up was 8487. I downloaded the latest OS X Firmware Updater to install firmware 8487, but that didn’t work (the updater software kept displaying an error message). I’ve now managed to install 83859 using the Windows installer, and playlists appear to be working properly now. I’ll have to do some more testing but it’s looking good.

    I really hope it’s easier from now on…

    #25833
    Tom SailorTom Sailor
    Participant

    Glad to hear you sorted it out Steve! Hope you enjoy the unit and sorry for not responding sooner.

    Tom Sailor

    #25842
    Steven CowleySteven Cowley
    Participant

    One confusing issue was the firmware version shown during bootup – I wasn’t sure how you were numbering firmware versions and as the one already installed began “84” and the one shown as being the latest on the website began “83” I was a bit concerned that I was trying to go backwards, and thought that might be why the Mac firmware updater was crashing.

    #25844
    Laszlo .Laszlo
    Keymaster

    The latest firmware release: 83859

    The mac updater crashed on os x yosemite?

    #25845
    Steven CowleySteven Cowley
    Participant

    Yes, it crashed on Yosemite. To be accurate, it didn’t crash, but gave me an error message which meant it couldn’t update the firmware.

    #25846
    Laszlo .Laszlo
    Keymaster

    Do you remember what was the error message?

    #25847
    Steven CowleySteven Cowley
    Participant

    ERROR: ArchDl_GetDfuDeviceProperties failed. Error Code: 0xE00002C5

    #25848
    Laszlo .Laszlo
    Keymaster

    Many thanks for your prompt response.

    #25849
    Steven CowleySteven Cowley
    Participant

    You’re welcome 🙂

    #25850
    NodnasNodnas
    Participant

    Hello,

    I have the same problem here. I can play the songs from folder but I can’t get the playlist working!
    I didn’t know what I was doing wrong. I’ve bought the second unit recently so I could work with it at home (while the first one is built in our band’s gear).
    But still no luck at all. After I press PLAY (or footswitch), the hourglass symbol appears for a milisecond and nothing happens.
    Now I’m pretty sure that it has to be the firmware issue as Steven has found out.
    So I am going to try to upgrade FW (I have 84xx) and see if it’s working. I’ll let you know.
    Pete.

    #25851
    NodnasNodnas
    Participant

    OK,
    so I’ve just flashed FW V-83859 (the old one was V-8487) and LP-16 is UNUSABLE :angry:

    I used exactly this file “LivePlayer_LP-16_Firmware_Upgrade_83859_x64.exe” (I’m on Windows 7 64bit).
    Everything worked great, I got a message saying the firmware had been upgraded – “Upgrade successfully finished”.

    Now when I connect my USB flash disk, LP-16 tells me “MT USB device test – Please wait”,
    then it says “MT TEST passed, USB flash drive, free space: xxx GB”.
    Then the main MT screen shows up, showing “Song 1 of 15” etc.
    Then after approx. 4 seconds everything repeats (MT USB test, test OK, main MT screen) again and again…. until I switch it off.
    No button is working!

    I tried to re-flash FW once again but the result is the same.

    EDIT:
    I formatted my USB flash drive to NTFS and LP-16 indeed offered me to format it for using it with LP-16.
    I was able to press PLAY to format it. After formatting everything stays the same: LP-16 detects USB flash, passes the test and shows “No songs found” and then again the detection procedure, etc…

    #25852
    NodnasNodnas
    Participant

    EVERYTHING IS WORKING NOW!

    I’m taking back all my previous screams of pain 😉 But I’ve finally managed to get my LP-16 work again!

    So this is probably my last message. I decided not to delete/edit the previous messages even when I got everything sorted out, so that the other people might read it in case they might have the same problems.

    So I’ve narrowed my search for a culprit to a footswitch that’s already connected before power-on! What a nightmare! :ohmy:
    Once I disconnect a footswitch the endless loop “USB reading- USB test passed – MT screen” suddenly stops.
    Whenever I start LP-16 with a footswitch connected the whole situation repeats again :ohmy:

    And to make it even more mysterious – this strange behaviour is caused by Yamaha FC-5 momentary footswitch.
    If I plug-in a normal guitar cable everything works fine, no loop is going on. So I measured the pedal and it’s actually “normally closed”.
    I forgot about this fact a long time ago. (If I connect tip and sleeve on a connected guitar cable and power on LP-16, the same “loop” thing happens – obviously)
    I tried to set the footswitch pedal mode to “normally closed” but it didn’t help with the problem 🙁
    The cause for this strange behaviour is definitely shorted tip and sleeve terminals on footswitch jack / connector during unit’s power-up !

    I hope you’ll be able to solve this problem and offer firmware upgrade very soon. It’s very uncomfortable to remove a footswitch before power-on.
    Not that I can imagine how we’ll do it as our band’s LP-16 is built in a case with a limited acces to front connectors (as we dont need them so often and we had to save some space). Of course it’s possible to use a “normally” open footswitch and it’s gonna be OK (and we’ll have to do it this way in our case) but for the future problem free operation of LP-16 this should really be remedied.

    As far as the playlist issue is concerned – in my opinion Cymatic Audio should let the users know about the playlist problem in the first place. Not only in the forum but on the main web page.
    It’s only a coincidence that I’ve come across the playlist problem topic on the very same day Steven Cowley posted it (although I had been fighting it for several weeks already). I’ve been blaming myself for not knowing how to work properly with Playlist Editor… (which in fact I didn’t know at first :-)) But after trying every possible combination (right to the point where I thought that maybe the playlist and WAVs necessarily need to be exported directly to USB flash, not copied in system) I found that I was not the only one in the world to have the same problem. I wonder if Steven and I were the only two persons to complain about it since I think that the playlist functionality is the essential feature that people would be buying LP-16 for!
    Then there’s the V-83859 firmware problem with the footswitch pedal that needs to be addressed and solved as soon as possible. I wonder if anybody else can replicate this behaviour.

    I’m sorry for writing so many serious and sometimes contradictory messages in such a short time but believe me I’ve had a couple of very nerve-racking hours here… Going from almost 100% functional – to totally unusable – to almost 100% working LP-16 again in just a few hours is just insane 👿
    (I badly need a shot of my home-made ginger liquor to release the tension 😛 )

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.