Useless utrack after updates

Home Page Forums Cymatic Audio Forum uTrack 24 Useless utrack after updates

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29046
    RoiRoi
    Participant

    Hi there.

    I have encountered major problems with my utrack after updating the firmware.
    A while ago (i believe it was august) i stumbled on the (then) latest firmware for my utrack on this site.
    Thinking it might be a good idea to keep the device up to date… i downloaded the file and saved it on my usb drive.

    The utrack did not automatically update via the front usb port… so i decided to try and update via my network router.
    After a few errors (some notification about not being able to keep a decent connection) it finally said: burning to flash!
    So i checked the software version on the screen of the utrack and the update seemed to be successful.

    Then suddenly the device starting to act strange: flickering onscreen text *see attachment… and after a while a blank screen … then it just died.
    Very annoying ofcourse, so i started reading the online manual; looking for a factory reset: there is none? really?

    I was lucky to have kept a backup of the older firmware and was able (again after several errors and fails of the update function via router) to restore the utrack to its older firmware.

    … i convinced myself that this was just a bug in the update *since it was just released* and checked if other users on this forum were having the same problems as i did…. hoping for a fix or solution… but couldn’t find any relevant posts!

    I decided to keep the firmware as it was….since this experience took me way more time then expected…. and would check later for a even newer version of the firmware when available (thinking that wouldnt give me the same problems)

    Yesterday i was delighted to see that there was a firmware update (oct 2017) version 4064 available… so i started all over again: first tried to do an update with an usb stick again: that worked instantly! So after the update i was checking the newest features of the os…. updated all related sofware : uremote and utool and after that: putting the device back in usb interface mode (thats what i use it most for) …. and you wont believe what happend!!!!

    The device started to mess around again! flickering screen: blank screen: no communication with my computer …[macbook pro 2,3 GHz Intel Core i7 running yosemite] so it died again!! Maybe importend to add: problems accure when there is no usb stick inserted in front panel! and happens both in standalone and usb interface mode : the screen turns blank [no texts onlu blue backlit] and the device doesnt work at all!

    So for now: i downgraded the device again to : 3474 via network (ofcourse errors during uploading software…. so took a few time) and now it seems working again (for how long…. who knows)

    Just to be clear:
    This utrack never ever left my studio and hangs safe in a 19 inch rack high above floor level (it is relatively new and even has the foil on its screen)… i bought it new in March of this year at Thomann.

    I was thinking of buying another one to have 48 ins and outs for my mixing console…. but to be fair im kinda disappointed and doesn’t seem very reliable to this point. Hopefully you can clear things up on how to solve my update problems,… or do i just have a * faulty utrack? (*if so; i would like to use warranty to swap it for a new decent working one.)

    Im happy to hear from you!
    with kindest regards Roi

    #29050
    Laszlo .Laszlo
    Keymaster

    Hi Roi,

    This problem it seems most likely hardware related. I see you experienced same behavior with different firmwares but my opinion this is just the bad luck. You experiences some issues which not related at all to the firmware release as we are include the same display driver inside of the firmware release. Your device have to work with the latest firmware release with no problem. I suggest you to report that problem to Thomann and ask a replacement device.
    Sorry for the convenience.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.