Home Page Forums Cymatic Audio Forum uTool uTool not seeing full length files

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #36915
    Fred Pellegrini

    While doing 1 hour performance recordings (each band got a one hour set) we encountered the following issue: If we had left uTool running in the background between extraction process with uTool, instances occurred where the uTool did not ‘see’ the full length /data size of the .wav files. It happened on both Mac and Windows machines with latest OS’s. We are guessing this is a JUCE file enumeration synchronicity issue, but are unable to test this theory.
    The issue has not happened if we close/reopen the uTool software between each extraction session.
    Also, we tested it with 2 different types of USB drives (manufacturer and RPM speeds) and that made no difference.
    We have updated our uTrack 24’s with latest firmware and are running latest update of uTool software. Any help with this would be greatly appreciated!



    Do I understand correctly your workflow?:
    1) open uTool and import some data from USB drive
    2) minimize uTool
    3) remove the USB drive from the computer, plug it in the uTrack, record…
    4) unplug the USB drive from the uTrack and plug it in the computer while uTool is still minimized
    5) maximuze uTool -> the USB drive content is probably not updated on screen.

    Fred Pellegrini

    1) Plug in USB drive with 2 Full 1- hour recordings (2 sets, each an hour), showing on USB as 2 Playlists.
    2) Open uTool and import .wav files for Show A. These show up fine and normal.
    3) While uTool is still open, go to Show B, and these files show up (as condensed track format files) as incorrect data size and if we try to run the extraction process the result is incomplete files.

    If we close the uTool between import sessions it seems to work fine. It only happens with multiple shows on one USB drive.

    Fred Pellegrini

    Hello? Any response would be appreciated.


    Hi Fred,

    I’m sorry for the delay.
    We have tried to reproduce the issue with no success.

    Maybe we are doing differently.

    I have couple of questions:
    1. if you select both two recording to import does both two recording has a correct size?
    2. In your workflow the second recording all the time shows up as an incorrect size? All the time show the same (incorrect) length? If yes what is the size/time of the file?
    3. Are those 24ch/48K/24 bit recordings?
    4. Do you have a same issue if the recordings are shorter than one hour?

    Fred Pellegrini

    Thanks for looking into this. Answers:
    1) We never select both recordings to import at the same time. We run 2 uTrack 24’s synced together, and we extract each show from both USB drives. So for example, each Show gets 2 USB drives, one for each unit. So for 2 shows, there are 4 files, 2 on each drive. The error generally only appears on one of the 2 drives for the Second show. The size difference displayed in the uTool (right side window when displaying what Playlists are available for import) may or may not be correct, experience has taught me to glance at the length of file displayed – not Data size. This is where the issue becomes visible. If we close and re-launch uTool, the Second show seems to have shown up properly with our experience. The issue only happens if we do not close and re-launch uTool.
    2) No, it does not happen 100% of the time. I estimate it is only maybe 1 out 20 or so. Again, we record about 150 shows in 6 days at our biggest festival. We have 12 uTrack 24’s, 6 stages each get 2 synced uTrack 24’s so we have 6 – 48 channel ‘units’.
    3) Due to the very large amount of data we process and archive for this festival we record at 16 bit/44.1 kHz. However, at another recent job I ran them at 24 bit 48 kHz and the error occurred once (out of 16 shows.)
    4) Some shows were less than an hour but not much less, perhaps shortest was 45-50 minutes of recording time. I cannot answer this accurately though as I do not remember if the shows that had the issues were shorter than an hour. I can say 98%+ of the shows are an hour or slightly longer. The error that happened recently while recording at 24/48 was a 90 minute performance.

    Again, this issue only happens when there is more than one ‘playlist’ on a drive and if uTool is not closed and re-launched before uncompressing. Since we have identified this issue, it is company procedure to close the uTool software after each import.
    We are very happy with the functionality of these machines overall. I do have one unit that is having issues we would like to take for repair or analysis – is there a U.S. based company you would recommend for this?
    Thank you for your time in looking into all of this. We appreciate it. http://www.MunckMusic.com is our website, and a large percentage of the recordings (since 2016) have been done with the uTrack 24’s.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.