uTrack 24 – Blank White Screen on Power up – Is it the power supply?

Home Page Forums Cymatic Audio Forum uTrack 24 uTrack 24 – Blank White Screen on Power up – Is it the power supply?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #76637
    Hartt RecordingHartt Recording
    Participant

    Hi all,

    Wondering if anyone has had the problem that when they power up their uTrack 24 they get a blank white screen and no other activity? No other lights on the front come on. My first thought was the power supply but I have not had a chance to check the voltage output yet. I just ordered a replacement so I guess we’ll see in a few days if that is the problem. Any info you may have would be appreciated.

    Thanks,

    Justin

    #76655
    Hartt RecordingHartt Recording
    Participant

    Update – just found another post about checking the ribbon cable inside since it may have come loose. I will check that soon as well.

    #77889
    Hartt RecordingHartt Recording
    Participant

    Not the ribbon cable. Tried reseating that and no difference. The power supply tests fine but I haven’t had a chance to try out the new one yet. Not looking too promising.

    #79102
    Laszlo .Laszlo
    Keymaster

    Hello,

    Sorry for the late reply.
    To me it sounds there’s an issue with the uRec2500 module inside of the device.
    Is the device still covered by warranty?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.