Home Page Forums Cymatic Audio Forum USB Drives General uTrack – Toshiba USB3 Flash Problems

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #28836
    Dylan Mitrovich

    Hi there

    Today I purchased 2 new Toshiba 16gb USB3 flash drives.

    Popped the first one in (brand new, out of packet), asked to format, all good.

    Loaded new firmware onto uTrack with said USB. All good. Firmware up to date.

    Loaded playlist and multi-track songs with uTool. All good.

    Tried loading on uTrack. uTrack briefly says mounting drive, then the screen goes white. All transport buttons flash white around once every 8 seconds (as well as a couple of off shapes on the screen), and nothing happens. When I take the uTrack out, it reverts to ‘disconnected’.

    Funnily enough, I take the 2nd Toshiba drive out of the packed, and exactly thing same thing happens – screen goes white etc.

    Tried re-formatting drives. No luck, same issue occurring.

    Try another USB flash drive (different brand). Works totally fine, from reformat, to loading songs on uTrack.

    Any ideas? Maybe an incompatibility with the Toshiba drives?



    Until that moment there’s no other person who report any similar issue with this drive.
    There was an issue with some of the Kingston DT micro drives where the connector pins sits little bit too deep inside of the USB connector that caused similar issue (because of the loose connection)
    If this is a same problem you can test that easily to pull back a little bit the drive. I mean when you connect the drive don’t insert fully in.
    I looking forward for your feedback


    I have the same problem with that drive. Dylanm, who have you fixed it?

    Dylan Mitrovich

    I just don’t use the Toshiba drives on the UTrack any more. Other drives work fine but not this.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.