Win10 reports driver UNSIGNED and will not install

Home Page Forums Cymatic Audio Forum uTrack 24 Win10 reports driver UNSIGNED and will not install

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #27383
    Mike ToddMike Todd
    Participant

    Bought uTrack24 earlier this week and am trying to install the USB driver (Windows USB ASIO/WDM Drivers V6.18.0 (Nov 9th, 2015)) on Win10/64 laptop.

    Windows reports that it cannot install as the driver is unsigned. So I used Microsoft’s nasty workarounds for this and it did install.

    However, while it now shows in Device Manager, it has a ! and the report that the driver is unsigned. Even uninstalling it, and the reinstalling from the .INF file results in the same issue.

    This is a fairly new laptop with a very recent reinstall of Win10 (done because I wanted to repurpose the laptop for audio use (rather than due to any problems) so there are no additional drivers or other software installed.

    The odd thing is that, if I run SIGVERIF (which scans all installed drivers) the driver (utrack24_usb_x64.sys) is there and showing “SIGNED”.

    So I reinstalled Win10 from scratch and re-downloaded the driver and still have the problem.

    I had hoped to use this tonight, but unless I get the driver installed I’m stuffed.

    Others must have installed the drivers on Win10, so I wonder if they hold the solution.

    Very frustrated.

    Oh – while I know it’s irrelevant, uTrack24 is v3474

    #27395
    Mike ToddMike Todd
    Participant

    UPDATE – on a different, brand new WIn10 machine – out of the box Win10 installation. NO updates (W10 Home, v1607, build:14393.0)

    Cannot install driver because it is detected as UNSIGNED.

    Updated Win10 with all the most recent updates – STILL cannot install driver because it is detected as UNSIGNED.

    HELP!!!!!!!!!!!

    #27402
    Mike ToddMike Todd
    Participant

    Still no success after 20+ hours working at this!!

    The Cymatics fix (install KB3194496) doesn’t work. Only possibility is to go back to Win10/v1511 or Win8.1, which I cannot do.

    So I’m stuffed and have a $1000 brick since I cannot use the uTrack24 for its intended use.

    There is onus on Cymatic (or Archwave) to understand what’s wrong and either release a driver that WILL load (I’ve installed several properly-signed drivers today, so it can be done) or admit that USB isn’t going to be an option until MS sort things out.

    #27404
    Mike ToddMike Todd
    Participant

    I make no apology for raising this issue again as it is critical/serious.

    Having had a very long discussion with Microsoft Support, it seems that the Anniversary Edition update (v1607) now enforces very strict driver rules, and drivers that do not conform cannot be installed. They did some checks and determined that the Cymatic audio driver does not conform and will never be able to be installed on win10 now or in the future.

    They say that developers were advised of this intent over two years ago, reminded again in 2015 and earlier this year that they must go through a new, much stricter, driver signing process. They say that I must go back to the originator and get them to fix the signing as no win10 update will fix this.

    Now I’ve no idea whether they speak the truth, but it does seem plausible.

    I’ve had to revert to a clean install of v1511 (which MS will not allow to activate) to allow me to continue working. But could someone from Cymatic perhaps comment as to whether their driver will go through the new signing process, and when.

    #27405
    ChetanChetan
    Participant

    HI Mike,

    Windows did release a new signing mechanism which we adopted early this year and made a release of all the drivers in September 2016 after due testing.

    Unfortunately after the upload to the website the date (Sep 2016 instead of Nov 2015) was not updated. It means that 3 days ago when you reinstalled the driver you actually had a properly signed driver. The date is corrected now. We have tested all the drivers on many Windows 10 PC without ever seeing this problem.

    It is quite strange that the driver shows unsigned on your PC. I just downloaded the driver and did a clean install on my Windows 10 PC and it does not show as unsigned. Could you zip and send us the exe file to support@cymaticaudio.com

    #27409
    Mike ToddMike Todd
    Participant

    Ok – decided to have one more go.

    Wiped my laptop HDD, installed latest w10 installation (downloaded from MS this morning), applied all updates, downloaded the driver file from your site and installed it. The installation was reported to be okay.

    But now, the moment I plug in the uTrack24 I get a blue screen. If it’s left plugged in, Win10 just keeps crashing and rebooting.

    I’ve attached the bluescreen image (I tried before with a couple of images and the crash MEMORY.DMP file, but just get thrown back to the forum).

    I cannot spend any more time on this and must go back and reinstall v1511 to allow me to use the uTrack24.

    #27411
    Mike ToddMike Todd
    Participant

    Okay – further to this – I’ve emailed you a ZIP containing both the installation EXE (as downloaded from your site this morning with win7/Chrome) and a minidump following the bluescreen.

    Interestingly, although you say you released new drivers in September 2016, the minidump shows that the two drivers that were installed are timestamped 10/11/2015 – these would be system timestamps, suggesting that they’re the wrong drivers.

    #27412
    ChetanChetan
    Participant

    Hi Mike,

    Thanks for the zip file. I had a look at it and it is exactly the one we uploaded on the website. Even the dates of the .sys files inside are from Sep 2016. What is strange though is the fact that the drivers in your dump are time stamped with the previous version of the driver.

    I fear that because we did not change the version number of the driver(after the new signature), the install did not probably replace the old files with the new ones.

    Could you try the following:
    1. Uninstall the uTrack24 driver from Control Panel -> Programs -> Programs and Features
    2. Manually delete the two .sys files (utrack24_usb_avs_x64.sys and utrack24_usb_x64.sys) from C:WindowsSystem32drivers if they still exist in that location.
    3. Install the uTrack24 driver again.

    Im hopeful that this will work for you.

    On our side to avoid further problems like these we will probably change the version number of the driver or find a way to make sure that the driver install cleans up the old files.

    #27413
    Mike ToddMike Todd
    Participant

    Thanks.

    Remember that I’m installing on a completely virgin win10 installation, so there would be no previous drivers. But, even after installation, the drivers are not located in WindowsSystem32drivers – they are only in the cymaticaudiouTrack24 folder. Deleting all of this (and searching the driver

    If I examine the drivers in more detail, I do see that they are signed by Archwave Technology BV, and dated 5 September 2016. The Inf file date has 11/9/2015 with the version, 6.18.0 but the minidump dates them the following day at 10/11/2015 (first is US mm/dd/yyyy but second is rest-of-world dd/mm/yyyy)

    Although I write software, I’ve not written drivers and I don’t know where or how the data is encoded in the .SYS files.

    Clearly the fact that everything is perfect under v1511 but not under v1607 suggests that there’s a significant problem running under the latter. Whether it’s v1607 or the uTrack24 drivers is difficult to say, but also it seems odd that you can install to a virgin v1605 with no problem whereas I can’t. Maybe there’s some interaction between the uTrack and some other driver.

    It’s also interesting that, going through exactly the same process, I was previously just getting driver signature issues – now I just get bluescreens.

    However, other than locking myself into v1511 from now on, I really don’t know what else to do!

    #27414
    ChetanChetan
    Participant

    Hi Mike,

    My PC Is still on v1511. The problem that I was investigating was why the driver showed as Unsigned on your PC.

    But my colleagues here tried with the Windows 10 Anniversary update and all the PC’s had a crash. After updating with the windows install KB3194496, one of the PC was OK, but the other one did crash (like yours).

    As of now we are investigating the reasons why this anniversary update is causing the problem. If you look up online the anniversary update has caused some other problems with other devices and drivers too.

    As of now, all I can say is that reverting back to v1511 seems to be the only properly working solution.

    #27416
    Mike ToddMike Todd
    Participant

    Well – it seems like there are two problems here, and the (genuine) unsigned driver issue was masking the bluescreen.

    Initially it was definitely that the signature was invalid on v1607 (under v1511 it was fine) – and I now know why and can replicate and fix it thanks to PreSonus technical support who said that there was a problem if their driver is downloaded using IE11 or Edge. Initially it had been fine for me on v1607 (I’d been installing from a memory stick), but It was suddenly showing the same “unsigned driver” issue when installed from a download.

    The solution was simply to download it using Chrome or Firefox – it installed just fine.

    This was clearly what was happening to the uTrack24 driver. It was getting installed/initialised, but wouldn’t run because its signature was not recognised. As a result, the bluescreen issue didn’t show itself.

    During the multiple reinstalls of Win10 I had unwittingly worked around this problem by grabbing the driver installation file from an old XP computer and put it on a memory stick.

    The uTrack24 driver was now getting installed, which revealed the bluescreen issue (which also only happens on v1607 and not on v1511).

    I’m glad that you’ve now been able to replicate this problem and I look forward to seeing a fix.

    But it’s worth being aware that, when it does get fixed, it will probably still not install on v1607 if the installation file is downloaded with IE11 or Edge (this would appear to be an issue of which MS has been aware for some time, but hasn’t fixed).

    I hope this helps

    #27417
    ChetanChetan
    Participant

    Hi Mike,

    Thanks for this info. We had no clue about this problem with IE11 and Edge.

    I will update you once we fix the driver for v1607.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.